Can't build Java 7 on my Mac

Senusi Lewis sjlewis01 at
Sun Dec 1 08:24:47 PST 2013

This is a recording/transcript of what i did to install Java onto my machine. This will contain the steps and the results so i can verify where it got screwed up..

My Machine is the following:

 Model Name:    Power Mac G5
  Model Identifier:    PowerMac7,3
  Processor Name:    PowerPC G5  (3.0)
  Processor Speed:    2.5 GHz
  Memory:    4 GB
  System Version:    Mac OS X 10.5.8 (9L31a)
  Kernel Version:    Darwin 9.8.0

Logged in under senusilewis as user and as administrator for the session

    1.    Download the binaries.
    2.    Copy the binaries to /usr/local/XXX where the XXX represents the binary package like /usr/local/openjdk7-zerovm-ppc-jyeary-2012-02-16-07-18-b00
    3.    Test the installation.

Started Terminal and copied the file  into my downloads folder and unzipped it. Made the /usr folder visible and moved it into the /usr/local/folder/

/usr/local/openjdk7-zerovm-ppc-jyeary-2012-02-16-07-18-b00/bin/java \-version
openjdk version "1.7.0-internal"
OpenJDK Runtime Environment (build 1.7.0-internal-jyeary_2012_02_16_07_18-b00)
OpenJDK Zero VM (build 21.0-b17, interpreted mode)

Sicne that worked I installed Mercurial and the forest extension since it was mentioned in the sample given.  I don't have MacPorts installed so i don't know if this would effect anything else.

hg --version
Mercurial Distributed SCM (version 2.0.2+20120104)
(see for more information)

Copyright (C) 2005-2011 Matt Mackall and others
This is free software; see the source for copying conditions. There is NO
senusis-power-mac-g5:~ senusilewis$ 

cat .hgrc
username = Senusi Lewis <>

Since i had a similar .hgrc file i kept going

hg clone
cd bsd-port
chmod 755

I ran through the process and got no visible errors when i tried the next line i got this for the directory..

ls -l
total 664
-rw-r--r--   1 senusilewis  staff    1503 Nov 30 19:17 ASSEMBLY_EXCEPTION
-rw-r--r--   1 senusilewis  staff   19263 Nov 30 19:17 LICENSE
-rw-r--r--   1 senusilewis  staff   16341 Nov 30 19:17 Makefile
-rw-r--r--   1 senusilewis  staff    1808 Nov 30 19:17 README
-rw-r--r--   1 senusilewis  staff  112920 Nov 30 19:17 README-builds.html
-rw-r--r--   1 senusilewis  staff  172252 Nov 30 19:17 THIRD_PARTY_README
drwxr-xr-x  12 senusilewis  staff     408 Nov 30 19:18 corba
-rwxr-xr-x   1 senusilewis  staff    1376 Nov 30 19:17
drwxr-xr-x  14 senusilewis  staff     476 Nov 30 19:36 hotspot
drwxr-xr-x  16 senusilewis  staff     544 Nov 30 19:24 jaxp
drwxr-xr-x  16 senusilewis  staff     544 Nov 30 19:22 jaxws
drwxr-xr-x  13 senusilewis  staff     442 Nov 30 19:37 jdk
drwxr-xr-x  13 senusilewis  staff     442 Nov 30 19:20 langtools
drwxr-xr-x  18 senusilewis  staff     612 Nov 30 19:17 make
drwxr-xr-x   3 senusilewis  staff     102 Nov 30 19:17 test

There it looks similar except that in the example results given. There were no .hg, .hgtags or .hgingore files. I was not sure if this wars corrrect so i continued with this part.

cd bsd-port
time env -i \
 PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin \
 make \
 CC=gcc-4.2 \
 CXX=g++-4.2 \
 ALT_BOOTDIR=/usr/local/openjdk7-zerovm-ppc-jyeary-2012-01-18-b00 \
 ALT_CACERTS_FILE=/System/Library/Frameworks/JavaVM.framework/Home/lib/security/cacerts \
 LIBFFI_CFLAGS="-I/usr/include/ffi" \
 DEFAULT_LIBPATH="/lib:/usr/lib:/usr/X11R6/lib:/usr/local/lib" \
 NO_DOCS=true \
 ZERO_BUILD=true \
 ZERO_ARCHFLAG="-arch ppc" \

I  got this as the result and it wasn't built.

env:  make: No such file or directory

real    0m0.072s
user    0m0.001s
sys    0m0.005s

What does that mean and what happened?

Senusi Lewis 
Amateur Writer and Gardener 
Library Assistant 1
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the bsd-port-dev mailing list