dacapo bloat benchmark fails on openjdk7

Luca Martini luca.martini at iet.unipi.it
Wed Aug 27 08:34:54 UTC 2008

Apologies for cross posting to the dacapobench-researchers and
build-dev at openjdk lists.

Hi all,
I recently tried to execute the DaCapo benchmark on OpenJDK 7 and I
found that "bloat" benchmark fails with the following exception:

$  OpenJDK/jdk7/build/linux-i586/j2re-image/bin/java-jar
~/dacapo-2006-10-MR2.jar bloat
===== DaCapo bloat starting =====
** Exception while optimizing
transform(LEDU/purdue/cs/bloat/editor/MethodEditor;)Z of class
String index out of range: -1802716504
java.lang.StringIndexOutOfBoundsException: String index out of range:
	at java.lang.String.getChars(String.java:860)
	at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:408)
	at java.lang.StringBuilder.append(StringBuilder.java:136)
	at java.lang.StringBuilder.append(StringBuilder.java:132)
	at java.util.AbstractCollection.toString(AbstractCollection.java:439)
	at java.lang.String.valueOf(String.java:2838)
	at java.lang.StringBuffer.append(StringBuffer.java:236)
	at EDU.purdue.cs.bloat.util.Graph$4.next(Graph.java:983)
	at java.util.AbstractCollection.addAll(AbstractCollection.java:322)
	at EDU.purdue.cs.bloat.optimize.Main.bloatMethod(Main.java:1078)
	at EDU.purdue.cs.bloat.optimize.Main.editClass(Main.java:688)
	at EDU.purdue.cs.bloat.optimize.Main.main(Main.java:446)
	at dacapo.bloat.BloatHarness.iterate(BloatHarness.java:25)
	at dacapo.Benchmark.run(Benchmark.java:126)
	at dacapo.TestHarness.runBenchmark(TestHarness.java:302)
	at dacapo.TestHarness.main(TestHarness.java:242)
	at Harness.main(Harness.java:5)

I really don't know if it's a DaCapo problem or if I missed something in
the build process of OpenJDK. The version of the DaCapo is 2006-10-MR2.
I built OpenJDK both using mercurial repository and source bundle, and
the build runs fine but when executing the benchmark the same error come
up. These are the options I used for building OpenJDK 7:

FINDBUGS_HOME= <local path for findbugs>
ALT_BINARY_PLUGS_PATH= <local path for binary plugs>

Here there are some information on my machine:

$ uname -a
Linux 2.6.24-21-generic #1 SMP Tue Aug 12 13:37:22 UTC 2008 i686 GNU/Linux

Any clues? Can anybody confirm such error?
Thanks for your attention,

Ing. Luca Martini
Dipartimento di Ing. dell'Informazione
Università di Pisa
Via Diotisalvi, 2, I-56126 Pisa, Italy
Tel: +39 050 2217 465
Fax: +39 050 2217 600
e-mail: luca.martini at iet.unipi.it

More information about the build-dev mailing list