Build problems on OpenSolaris (ccfe killed)

Clemens Eisserer linuxhippy at
Sun Aug 31 13:52:16 UTC 2008


For some while now I am trying to build OpenJDK on OpenSolaris.
It worked well on 2008.05 after changes that made the system non
bootable (installing SUNWtoo made it build, but the system did not
boot after this).

Because of this and some other problems I experienced I tried
OpenSolaris-build95, however now the build aborts reporting ccfe was

> ........ -c -o /export/home/ce/..../tmp/sun/font/layout/CursiveAttachementSubtables.o ../../../src/share/native/sun/font/layout/CursiveAttachementSubtables.cpp
> CC: Fatal error in ccfe: Killed
> sun.font/fontmanager/obj/CursiveAttachmentSubtables.o Error 1
> ****gmake: Waiting for unfinisged jobs...
> ****gmake: Error 2

Is this a known problem? Any ideas what I could do to solve this?
The only things I did to the system was installing the headers, gcc
and SunStudio via the OpenSolaris repository.

Thank you in advance, Clemens

More information about the build-dev mailing list