Build problems on OpenSolaris (ccfe killed)

Kelly O'Hair Kelly.Ohair at Sun.COM
Sun Aug 31 17:04:34 UTC 2008

Did you see:

But more information would help and the information you have
provided has some strange spelling errors, like
CursiveAttachementSubtables vs. CursiveAttachmentSubtables
and unfinisged vs unfinished.
A proper cut&paste of the error would help, with perhaps a few
more lines of the tail of the log file?

First os all, what version of CC are you using and where did it come from?

My first impression is that this is an issue between Solaris and
the Sun Studio compiler, perhaps tickled out during a compile of
an OpenJDK source file. So you should probably be posting something
on the Sun Studio forum site:

Finding any core file that might be left around and running:
    dbx - core
on that file would also help, use the 'threads' and 'where' commands
in dbx to see if you can further isolate where the process death is
dbx will also tell you exactly what executable image core dumped,
there are many it could possibly be.

The SUNWtoo package contains some critical parts of the system that
must interact well with the Sun Studio compilers. Any issue or
problem with what SUNWtoo installs will probably cause the Sun Studio
compilers to mis-behave.
I don't know if any issues here, but that doesn't mean there aren't
any, you should try and post something on the Sun Studio forum and
ask if there are known problems. Include the specifics of exactly
what Solaris image and SUNWtoo package you are using, including
what CC compiler you are using.


Clemens Eisserer wrote:
> Hi,
> For some while now I am trying to build OpenJDK on OpenSolaris.
> It worked well on 2008.05 after changes that made the system non
> bootable (installing SUNWtoo made it build, but the system did not
> boot after this).
> Because of this and some other problems I experienced I tried
> OpenSolaris-build95, however now the build aborts reporting ccfe was
> killed/died:
>> ........ -c -o /export/home/ce/..../tmp/sun/font/layout/CursiveAttachementSubtables.o ../../../src/share/native/sun/font/layout/CursiveAttachementSubtables.cpp
>> CC: Fatal error in ccfe: Killed
>> sun.font/fontmanager/obj/CursiveAttachmentSubtables.o Error 1
>> ****gmake: Waiting for unfinisged jobs...
>> ...
>> ****gmake: Error 2
> Is this a known problem? Any ideas what I could do to solve this?
> The only things I did to the system was installing the headers, gcc
> and SunStudio via the OpenSolaris repository.
> Thank you in advance, Clemens

More information about the build-dev mailing list