OpenJDK does not build on Solaris nv82

Tim Bell Tim.Bell at Sun.COM
Wed Feb 6 01:41:17 UTC 2008

Max (Weijun) Wang wrote:
> The bug was identified 8 weeks ago?


> Anyway, this demonstrates that even us Sun employees don't have an 
> internal code repository for latest code fixes. :'(

Well - we do - I don't know offhand where Kelly's repo is, but I could dig it up in my email 
archive.  I wish we didn't have the current state of affairs either.

My only note as I head for the exit and start cooking dinner is that Solaris Express (also 
known as Solaris 11) is not an "official" build platform for JDK 7.  We always want to be able 
to build on the very latest Solaris release (that is what I run, all the time, as much as 
possible), but the JDK7 Release Engineering builds are done on Solaris 10 Update 3 (I just 
checked), and those are not affected by 6637583.

We will fix this as soon as we can.


> Thanks all.
> Max
> On Feb 6, 2008, at 1:41 AM, Tim Bell wrote:
>> Alexey Ushakov wrote:
>>> Hello Max,
>>> Actually, we've already found this problem and passed to the team 
>>> responsible for the code (Cannot provide you  bug id at the moment 
>>> though, but will do as soon as I get it). For now you can use 
>>> following workaround in openjdk sources (that worked for me):
>> This is Bug-ID 6637583
>> Build failure on latest Solaris, source missing include of resource.h?

More information about the build-dev mailing list