Self-built JDK has troubles reading jar-files

Andrew John Hughes gnu_andrew at
Tue Nov 3 21:56:36 UTC 2009

2009/11/3 Clemens Eisserer <linuxhippy at>:
> Hello,
> I've just tried syncing with master, however my build doesn't seem to
> be able to handle jar-files - even with a fresh clone of jdk7/jdk or
> jdk//2d/jdk:
> [ce at localhost linux-i586]$ bin/java -Dsun.java2d.xrender=True -jar
> /fc8/usr/j.jar
> Exception in thread "main" java.lang.NoClassDefFoundError: java2d/Java2Demo
>        at java.lang.ClassLoader.findBootstrapClass(Native Method)
>        at java.lang.ClassLoader.findBootstrapClassOrNull(
>        at java.lang.ClassLoader.loadClass(
>        at java.lang.ClassLoader.loadClass(
>        at sun.misc.Launcher$AppClassLoader.loadClass(
>        at java.lang.ClassLoader.loadClass(
>        at sun.launcher.LauncherHelper.checkAndLoadMain(
> Applications start up, after I unzip their jar-files and state the
> main-class explicitly.
> Any ideas what could be the problem? I am building on Fedora12 Beta, x86.
> Thank you in advance, Clemens

Difficult to say from just that.  Have you tried using the freshly
built JDK to build itself?  It's a quick acid test of a new build, and
something IcedTea does by default.
Andrew :-)

Free Java Software Engineer
Red Hat, Inc. (

Support Free Java!
Contribute to GNU Classpath and the OpenJDK

PGP Key: 94EFD9D8 (
Fingerprint: F8EF F1EA 401E 2E60 15FA  7927 142C 2591 94EF D9D8

More information about the build-dev mailing list