'One-off' directory error when running jtreg

Martijn Verburg martijnverburg at gmail.com
Thu Apr 12 08:27:44 UTC 2012


Hi all,

That did trick, thanks all.  Will try the build-infra build next.

Cheers,
Martijn

On 9 April 2012 21:01, Kelly O'Hair <kelly.ohair at oracle.com> wrote:

> Set PRODUCT_HOME manually.
> The Makefile can only guess where the build might be, and although we
> could add in a second guess, that
> could be a problem too.  Setting PRODUCT_HOME on the make command line
> will guarantee what it uses.
>
> -kto
>
> On Apr 9, 2012, at 12:28 PM, Martijn Verburg wrote:
>
> Hi all,
>
> I'm building the full tl project (which builds fine) and am then running
> the jtreg tests for the jdk util package (from $OPENJDK_SOURCE/jdk/test)
> with:
>
> make jdk_util > test.log
>
> I seem to be getting a one-off error with the directory structure that
> it's looking for with regards the java executable that's been built, e.g.
>
> ACTION: build -- Error. Cannot get VM for test: java.io.IOException:
> Cannot run program
> "/home/openjdk/sources/jdk8_tl/jdk/test/../build/linux-i586/bin/java" (in
> directory
> "/home/openjdk/sources/jdk8_tl/jdk/build/linux-i586/testoutput/jdk_util/JTwork/scratch"):
> error=2, No such file or directory
> REASON: Named class compiled on demand
> TIME:   0.021 seconds
> messages:
> command: build ToString
> reason: Named class compiled on demand
> elapsed time (seconds): 0.021
>
> This makes kind of sense since the java binary is actually at:
>
> /home/openjdk/sources/jdk8_tl/jdk/test/../../build/linux-i586/bin/java
>
> as opposed to:
>
> /home/openjdk/sources/jdk8_tl/jdk/test/../build/linux-i586/bin/java
>
> Should I be setting the $PRODUCT_HOME manually or have I done something
> wrong? :-)
>
> Cheers,
> Martijn
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/build-dev/attachments/20120412/d7d2ecec/attachment.html>


More information about the build-dev mailing list