Compiling Hotspot on Ubuntu 11.10

Developer Ubuntu pubuntup at gmail.com
Mon Apr 16 16:30:17 UTC 2012


..../hotspot/make/linux/MakeFile has following
line (233)
SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 2.7%

line (239)
>&2 echo "*** This OS is not supported:" `uname -a`; exit 1;

I got error compiling hotspot pn Ubuntu 11.10 having kernel version 3.0.x

Changing it to
SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 2.7% 3.0%
has worked.

Will it have any sideeffects?

Thanks,
pubuntup
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/build-dev/attachments/20120416/587b1a7f/attachment.html>


More information about the build-dev mailing list