Incorrect bootstrap jdk in documentation

Martijn Verburg martijnverburg at gmail.com
Sat Apr 21 15:07:43 UTC 2012


Hi John,

I'm not sure going forwards if the documentation is supposed to cover all
OpenJDK forests (in terms of version numbers, that is, OpenJDK 7 and
OpenJDK 8) or whether the documentation will diverge depending on what
forest you're in. I've got a few doc patches I'm holding off on until we
know which way this is going to go.

I've CC'd in Cecilia and Iris, (Ben and I had a meeting with Cecilia and
Tomas about this last week) to see if they can shed some light, as I know
they're intending to update the developer docs shortly.

Cheers,
Martijn

On 17 April 2012 15:03, John Oliver <johno at insightfullogic.com> wrote:

> I was building jdk8 and noticed that your documentation generally states
> that you need a jdk 1.6.0 as a bootstrap, in the following files:
>
> http://hg.openjdk.java.net/**jdk8/build/raw-file/tip/**README-builds.html<http://hg.openjdk.java.net/jdk8/build/raw-file/tip/README-builds.html>
> http://hg.openjdk.java.net/**jdk8/build/raw-file/tip/README<http://hg.openjdk.java.net/jdk8/build/raw-file/tip/README>
>
> When I tried to build using 1.6.0 I received the following:
>
> ERROR:Your  BOOTDIR  environment variable doesnot  point
>       to a validJDK  for  bootstrapping this build.
>       A  JDK  8   build must be bootstrapped using
>       JDK  1.7.0  fcs (or  later).
>       Apparently, your bootstrapJDK  is version1.6.0
>       Please  update yourALT_BOOTDIR  settingand  start your build again.
>
>
>
> When I retried using 1.7.0 as a bootstrap it was fine. I presume those
> files need to be updated to reflect that you now need at least 1.7.0.
>
> Thanks
>
> John
>
>
> --
> John Oliver
>
> InsightfulLogic
> http://www.insightfullogic.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/build-dev/attachments/20120421/72c339c5/attachment.html>


More information about the build-dev mailing list