sthjprtsol* machines

Kelly O'Hair kelly.ohair at
Mon Apr 30 22:02:53 UTC 2012

On Apr 28, 2012, at 5:05 AM, Heikki Härkönen wrote:

> Kelly O'Hair skrev 2012-04-27 23:52:
>> On Apr 27, 2012, at 8:28 AM, Kelly O'Hair wrote:
>>> Not sure this will catch you before you take off on your long vacation, so it's mostly for when you get back...
>>> 1. sthjprtsol06  isn't working, it almost acts like it might be in conflict with sthjprtsol08, maybe an IP address conflict?
> I didnt have any issues login in and I have verified that they have the right IP addresses.
> Here is a back-door to the systems in case of issues.
> is the "zone master" for sthjprtsol01-04.
> is the "zone master" for sthjprtsol05-08.
> Login into the host with ssh and same root/xxxxx password.
> To check which zones are configured:
> zoneadm list -cv
> To login into a zone:
> zlogin sthjprtsol01
> To execute a command in a zone:
> zlogin sthjprtsol01 ls -la

sthjprtsol06 seems fine now. Not sure what my problem was.  Ghosts in the machine. :^(

>>> 2. sthjprtsol09 thru sthjprtsol16 I cannot login to, they say "ssh: HOSTNAME:  temporary name resolution failure"
>>>   which is what sthjprtsol06 is saying now.  I'm trying to "ssh -l root HOSTNAME".
> the Sparc server, T4-1, we have to move the server to our datacenter which we will do next week so these will not work until next week.

Ah I knew this. Ok.

>>> 3. On the machine I have setup, sthjprtsol01-sthjprtsol05, sthjprtsol07 and sthjprtsol08. They seemed to work at first, but
>>> none of then can open a socket connection to the driver machine sthjprt over port 5555, and then I tried 5333.
>>> It's like the port connections are being blocked. So they cannot communicate to sthjprt over port 5333, and I suspect any port?
> my bad,the firewall was on on Solaris 10..... Gaaah, disabled with "svcadm disable network/pfil" should work now

I still cannot get this to work.
As far as I can tell, Solaris 11 does not have this service network/pfil

It's like the client machines think that the driver machine has no service running for that port.
Yet, when I run 'netstat -a' and search for the port, it has a LISTEN entry.

>> 4. The /jprt area on sthjprt needs to be nfs shared.
>> On Solaris 10 I knew how to do this, but on Solaris 11 I'm hopelessly lost.
> done!
> here is the commands:
> zfs set sharenfs=on jprt
> share -F nfs -o rw /jprt
> does it need to be read-write?

Yes. Needs to be read-write for now.  I can access it now.

> Other clients that are ready are:
> VMware server:
> sthjprtlin01-03, FC9 32bit
> sthjprtlin04-06, FC9 64bit
> VMware server:
> sthjprtlin07-09, FC9 32bit
> sthjprtlin10-12, FC9 64bit

Cool, I will get started on them.

> To manage VMware: and download the mgmt client (I think it is Windows only) username: root password: xxxxx <- same for all VMware hosts.
> Philip is almost done with the Windows XP, 2003 and 7 images, Cygwin was installing on 2 of them on Friday.
> We have got the paravirtualized drivers, network and disk, to work with Windows, Fedora 9 only works with the paravirtualized network drivers. For FC9 I also had to modify the kernel boot settings to include: "notsc  divider=10 nohpet clock=pit" 32bit didn't boot at all without these. Here is a VMware Best Practices for timekeeping in Linux: 
> After next week we hope to have all clients up and running.

Great, keep me informed.

The sockets not working is my biggest roadblock right now, but I need time to configure the systems anyway.


>> -kto
>>> Well, I'll mostly be relaxing today, since SCA is going down...  Had a great time and thank you for the dinner, it was great.
>>> Say hi to Anna .
> It was our pleasure :-) Anna says hi back.
> /Heikki
>>> -kto

More information about the build-dev mailing list