BootStrapping Hell

Senusi Lewis sjlewis01 at
Wed Dec 25 00:53:54 UTC 2013

I rechecked the directories three times and made sure they matched. I also tried it in X11. It still has problems building. 

It says this now.

make: ***empty varauble name. stop.

This is what i typed in:

cd bsd-port
time env -i \
 PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin \
 make \  (<-- there is a makefile in BSD folder)
 CC=gcc-4.2 \
 CXX=g++-4.2 \
 ALT_BOOTDIR=/usr/local/openjdk7-zerovm-ppc-jyeary-2012-02-16-07-18-b00 \  (<--- made sure that was correct)
 ALT_CACERTS_FILE=/System/Library/Frameworks/JavaVM.framework/Home/lib/security/cacerts \ (<---- Its and alias made by the system but its there)
 LIBFFI_CFLAGS="-I/usr/include/ffi" \
 DEFAULT_LIBPATH="/lib:/usr/lib:/usr/X11R6/lib:/usr/local/lib" \
 NO_DOCS=true \
 ZERO_BUILD=true \
 ZERO_ARCHFLAG="-arch ppc" \

It keeps hanging on this piece of code for the longest. 

I tried substituting make for make -debug and nothing happens except the same error. 

I made sure i was in the /users/senusiewis/bsd-port/ directory before  i continued. what am i not catching in this code?

Was there something that is supposed to be present prior to this mess? I don't want to install more useless modules without understanding what is wrong. The run around i am gettting is driving me nuts. Please double check with what this page says. Is there something i am not seeing?

I already downloaded Macports, Mercruial, mercurial forest and the java build for my Power Mac. What is the missing link?

Senusi Lewis 
Amateur Writer and Gardener 
Library Assistant 1

More information about the build-dev mailing list