X11/Intrinsic.h not found, ALT_X11_PATH=/opt/X11

Alan Bateman Alan.Bateman at oracle.com
Mon Jan 7 12:35:08 UTC 2013

On 07/01/2013 10:03, Joel Borggrén-Franck wrote:
> On 7 jan 2013, at 10:43, Alan Bateman<Alan.Bateman at oracle.com>  wrote:
>> I upgraded a Mac to 10.8.2 and Xcode 4.5.2 over the break, now I'm trying to get the jdk7u/jdk7u-dev, jdk8/tl and jigsaw/jigsaw forests building again. I installed XQuartz 2.7.2 so I have X11 and jdk8/tl builds fine with the new build (except for the "images" target, there's an issue with sed there).
>> For the old build (jdk7u-dev and jigsaw) then AWT won't build because it can't find X11/Intrinsic.h. With XQuartz then it looks like the X11 bits are in /opt/X11. The include files are there so I tried to build with ALT_X11_PATH=/opt/X11 but that doesn't help. Is there anything else I need to know?
> I have
> export CPATH="/usr/X11/include"
> set while building tl with the old makefile. There is an Intrinsic.h in /usr/X11/include/X11
Thanks that works (although I run into the same issue as the new build 
with sed when building images).


More information about the build-dev mailing list