X11/Intrinsic.h not found, ALT_X11_PATH=/opt/X11

David Chase david.r.chase at oracle.com
Tue Jan 8 00:03:06 UTC 2013

On 2013-01-07, at 2:41 PM, Kelly O'Hair <kelly.ohair at oracle.com> wrote:

> If someone could document everything that was done to get this working I would appreciate it.
> We have a bunch of 10.8 macs that we need to figure out how to get them to build the jdk for 10.7
> or we have to come up with a better answer.
> I assume Mac 10.7 support in jdk7u and jdk8 will continue, but when the newer Macs only work with 10.8
> that makes things difficult.
> -kto

New build worked last time I tried it; I will try again after sending this email.

I just tried this old-build script, which has worked before with jdk8 on a mac, but this time it failed bizarrely.

Script (invoked as "./macosmake all"):

export ALT_BOOTDIR=/Library/Java/JavaVirtualMachines/1.7.0.jdk/Contents/Home
export LANG=C
export LC_ALL=C
export X11_PATH=/opt/X11
export LP64=1
export OTHER_INCLUDES=-I/opt/X11/include
make "$@"

cd  /Users/dr2chase/work/jdk8tl/build/macosx-x86_64/j2re-image/lib && \
	    /Library/Java/JavaVirtualMachines/1.7.0.jdk/Contents/Home/bin/java -XX:-PrintVMOptions -XX:+UnlockDiagnosticVMOptions -XX:-LogVMOutput -Djava.awt.headless=true -Xmx512m -Xms512m -XX:PermSize=32m -XX:MaxPermSize=160m -jar /Users/dr2chase/work/jdk8tl/build/macosx-x86_64/btjars/buildmetaindex.jar \
		-o meta-index *.jar
Exception in thread "main" java.lang.StringIndexOutOfBoundsException: String index out of range: -7
	at java.lang.String.substring(String.java:1958)
	at build.tools.buildmetaindex.JarMetaIndex.isPrefixKnown(BuildMetaIndex.java:315)
	at build.tools.buildmetaindex.JarMetaIndex.getMetaIndex(BuildMetaIndex.java:233)
	at build.tools.buildmetaindex.BuildMetaIndex.main(BuildMetaIndex.java:97)
make[2]: *** [initial-image-jre] Error 1
make[1]: *** [jdk-build] Error 2
make: *** [build_product_image] Error 2

> On Jan 7, 2013, at 4:35 AM, Alan Bateman wrote:
>> On 07/01/2013 10:03, Joel Borggrén-Franck wrote:
>>> On 7 jan 2013, at 10:43, Alan Bateman<Alan.Bateman at oracle.com>  wrote:
>>>> I upgraded a Mac to 10.8.2 and Xcode 4.5.2 over the break, now I'm trying to get the jdk7u/jdk7u-dev, jdk8/tl and jigsaw/jigsaw forests building again. I installed XQuartz 2.7.2 so I have X11 and jdk8/tl builds fine with the new build (except for the "images" target, there's an issue with sed there).
>>>> For the old build (jdk7u-dev and jigsaw) then AWT won't build because it can't find X11/Intrinsic.h. With XQuartz then it looks like the X11 bits are in /opt/X11. The include files are there so I tried to build with ALT_X11_PATH=/opt/X11 but that doesn't help. Is there anything else I need to know?
>>> I have
>>> export CPATH="/usr/X11/include"
>>> set while building tl with the old makefile. There is an Intrinsic.h in /usr/X11/include/X11
>> Thanks that works (although I run into the same issue as the new build with sed when building images).
>> -Alan

More information about the build-dev mailing list