Yosemite problems with FreeType

Magnus Ihse Bursie magnus.ihse.bursie at oracle.com
Tue Nov 4 13:10:39 UTC 2014

On 2014-10-22 19:50, Dan Smith wrote:
> Well, I take that back.  Tried installing 2.7.5 just in case, and now it works fine.
> Summary:
> - Yosemite installer breaks XQuartz configuration (probably something trivial like removing a symbolic link)

There does indeed seem to be a missing symbolic link. In previous 
versions, I can find a symlink from libfreetype.6.dylib to 
libfreetype.dylib in /usr/X11/lib. In Yosemite, this is missing. This 
causes configure to fail.

I tried some ways to work around this in configure by using freetype.6 
as library name instead of freetype, but I kept running into one silly 
problem after another and decided it didn't really seemed worth it.

Instead of installing a different version of XQuartz, a workaround 
should probably be to:
cd /usr/X11/lib
ln -s libfreetype.6.dylib libfreetype.dylib
(but I have not tested this).

I think this will break other apps as well that want to use freetype, so 
a bug should probably be filed with Apple.


More information about the build-dev mailing list