Yosemite problems with FreeType

Dan Smith daniel.smith at oracle.com
Tue Oct 21 22:46:59 UTC 2014

Looks like I'm a little bit too close to the bleeding edge, but I wonder if anyone's looking into cleaning up building on OS X Yosemite (10.10).

Building jdk9 mostly works fine, but I've had issues with FreeType.

Problem #1:

> make dist-clean
> sh configure --with-boot-jdk=$JAVA8_HOME

configure: error: Could not find freetype!  
configure exiting with result code 1

(I tried re-installing XQuartz (updated to 2.7.7), in response to this or a similar error.  Not sure if that made any difference, but I still get an error.)

Workaround is to point directly to my X11 directories:
> sh configure --with-boot-jdk=$JAVA8_HOME --with-freetype-include=/usr/X11/include/freetype2 --with-freetype-lib=/usr/X11/lib

Problem #2:

> make images

xattr: No such file: /Users/dan/Dev/jdk/jdk9/build/macosx-x86_64-normal-server-release/jdk/lib/libfreetype.dylib.6
make[3]: *** No rule to make target `/Users/dan/Dev/jdk/jdk9/build/macosx-x86_64-normal-server-release/jdk/lib/libfreetype.dylib.6', needed by `/Users/dan/Dev/jdk/jdk9/build/macosx-x86_64-normal-server-release/images/j2re-image/lib/libfreetype.dylib.6'.  Stop.
make[3]: *** Waiting for unfinished jobs....
make[2]: *** [images] Error 2
make[1]: *** [main-wrapper] Error 2
make: *** [images] Error 2

If I skip the 'images' step, the build succeeds the first time (so I do get usable output, fortunately) but subsequently fails with:
> make

cp: symlink: libfreetype.6.dylib: File exists
make[3]: *** [/Users/dan/Dev/jdk/jdk9/build/macosx-x86_64-normal-server-release/jdk/lib/libfreetype.dylib.6] Error 1
make[2]: *** [java.desktop-copy] Error 2
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [main-wrapper] Error 2
make: *** [default] Error 2

I found /usr/X11/lib/libfreetype.6.dylib, and tried linking from or copying to /usr/X11/lib/libfreetype.dylib.6, but that didn't help.


More information about the build-dev mailing list