RFR: JDK-8058845 : Update JCE environment for build improvements
Alan.Bateman at oracle.com
Tue Sep 23 09:45:25 UTC 2014
On 21/09/2014 23:51, Bradford Wetmore wrote:
> Hi Sean/Mandy/Erik/Magnus/Alan/David/others,
> Please review:
> JDK-8058845 : Update JCE environment for build improvements
> This change is to alleviate some of the overly-complicated steps we
> (Oracle) have in building and maintaining the JCE jar files in JDK 9.
The overall change is very welcome.
I'm not an expert in this area but I have looked through the changes.
In JceSecurity maybe verifyProviderJar could be renamed to
verifyProvider or something better as it should not be limited to JAR
files. I also wonder about the name URLVerifier. With the current
implementation then JarVerifier is more obvious but of course that will
change very soon when we have security providers linked into the image.
Just mentioning it as renaming this to ProviderVerifier or something
better might make it a bit clearer.
More information about the build-dev