RFR: JDK-8078058 Clean up mac bundles logic
erik.joelsson at oracle.com
Mon Apr 20 06:57:30 UTC 2015
Looks good to me.
On 2015-04-17 14:20, Magnus Ihse Bursie wrote:
> The MacBundles logic needs some love.
> 1) The names defined in spec.gmk.in just says "bundle" but this is a
> somewhat overloaded term, shared e.g. by jprt. This should be renamed
> to macosx_bundle.
> 2) We should use the modern SetupTextFileProcessing to process the
> plist template files.
> 3) We should just clean up the open/non-open mess wrt names and
> version strings.
> I chose to keep the non-open versions, for several reasons. It's
> probably more likely that anyone is dependent on the more widely
> distributed Oracle JDK, so changing that would likely be more
> disruptive. And secondly, in one case the non-open version was more
> informative, which is likely to be a good thing. (In the other case,
> it was just a difference of using paranthesis or not.)
> Bug: https://bugs.openjdk.java.net/browse/JDK-8078058
More information about the build-dev