trouble setting up build environment on new linux system

Claes Redestad claes.redestad at
Tue May 3 18:10:23 UTC 2016

Have you tried jib to set up your build environment?

bash ./common/bin/ configure


On 2016-05-03 20:03, Steve Drach wrote:
> My linux system was upgraded to Oracle Linux 7u1 from Linux 6u5.  I manually installed, using yum, jdk1.8.0_92, ran configure with the following options,
> --disable-warnings-as-errors --with-boot-jdk=/usr/java/jdk1.8.0_92 and started  a make of jdk.  For the most part it worked fine until it got here:
> Building JVM variant 'server' with features 'all-gcs cds closed-src commercial-features compiler1 compiler2 fprof jni-check jvmci jvmti management nmt services trace vm-structs'
> /bin/ld: cannot find -lstdc++
> I see these libstdc++ on my system
> $ ls /usr/lib/*
> /usr/lib/      /usr/lib/
> /usr/lib/  /usr/lib/
> Do I need some other versions?  I can’t seem to find a configure option to point to those libs, but they seem to be in a pretty standard place.
> Any clues, or even better, a cheat sheet for OL 7.1?

More information about the build-dev mailing list