JDK 8 cannot be built on Sierra, correct?

Erik Joelsson erik.joelsson at oracle.com
Thu Feb 2 08:00:52 UTC 2017

There was a discussion about this a few weeks back, but you are correct. 
David DeHaven suggests creating a VM to build in.



On 2017-02-01 20:00, Jim Laskey (Oracle) wrote:
> I haven’t tried in a while, but I ran up against it today.
> Neither the xcode-select (xcode4) or configure --with-xcode-path work.
> dyld: Library not loaded: @rpath/DVTFoundation.framework/Versions/A/DVTFoundation
>    Referenced from: /Volumes/Elephant/Users/jlaskey/Downloads/Xcode4.app/Contents/Developer/usr/bin/xcodebuild
>    Reason: no suitable image found.  Did find:
> 	/Volumes/Elephant/Users/jlaskey/Downloads/Xcode4.app/Contents/Developer/usr/bin/../../../SharedFrameworks/DVTFoundation.framework/Versions/A/DVTFoundation: cannot load '/Volumes/Elephant/Users/jlaskey/Downloads/Xcode4.app/Contents/Developer/usr/bin/../../../SharedFrameworks/DVTFoundation.framework/Versions/A/DVTFoundation' because Objective-C garbage collection is not supported

More information about the build-dev mailing list