RFR: JDK-8187544 Replace BUILD_OUTPUT and OUTPUT_ROOT with OUTPUTDIR.
Magnus Ihse Bursie
magnus.ihse.bursie at oracle.com
Fri Sep 15 11:35:18 UTC 2017
On 2017-09-15 00:25, Erik Joelsson wrote:
> Also a good cleanup.
> In flags.m4, perhaps replace with SUPPORT_OUTPUTDIR?
Sure, I'll fix. (Not posting new webrev.)
> On 2017-09-14 14:14, Magnus Ihse Bursie wrote:
>> Due to historical reasons, we have had two variables that points to
>> the output directory (e.g. "$topdir/build/linux-x64"), one named
>> BUILD_OUTPUT and one named OUTPUT_ROOT.
>> First of all, these two should be unified into one.
>> Second, it should be renamed OUTPUTDIR to better align with other
>> variables such as TOPDIR, and the various *_OUTPUTDIR variables we
>> already have.
>> The only non-trivial part of this patch was the handling in
>> bootcycle-spec.gmk.in. I've verified that I can still build
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8187544
More information about the build-dev