RFR: JDK-8196724: Change macosx deployment target to 10.9

Gerard Ziemski gerard.ziemski at oracle.com
Wed Apr 4 20:11:12 UTC 2018


hi Erik,

Thanks for doing this.

I like how you are using a narrow mechanism to turn off only those warnings that come up due to deprecated APIs.

Just a quick verification question (not very familiar with the makefiles), in line like this:

DISABLED_WARNINGS_clang := deprecated-declarations

I assume we turn "deprecated-declarations” into “-Wdeprecated-declarations” flag that then gets passed to the compiler?


cheers

> On Apr 4, 2018, at 1:30 PM, Erik Joelsson <erik.joelsson at oracle.com> wrote:
> 
> This patch changes the values for the macosx version min and max settings from 10.7 to 10.9. It also changes the stdlib from libstdc++ to libc++ (explicitly for Hotspot and implicitly everywhere else). This change is necessary to keep up with newer toolchain versions on Macosx where using the old and no longer maintained libstdc++ has been deprecated. This is done in preparation for bumping the preferred Xcode version used for builds at Oracle.
> 
> The switch has been tested for both Hotspot and client.
> 
> The switch triggered some new deprecation warnings which have been silenced and followup bugs have been filed on the concerned team.
> 
> Bug: https://bugs.openjdk.java.net/browse/JDK-8196724
> 
> Webrev: http://cr.openjdk.java.net/~erikj/8196724/webrev.01/index.html
> 
> /Erik
> 



More information about the build-dev mailing list