<AWT Dev> RFR: 8196516: libfontmanager must be built with LDFLAGS allowing unresolved symbols

Severin Gehwolf sgehwolf at redhat.com
Tue Apr 10 11:30:56 UTC 2018


On Mon, 2018-04-09 at 15:39 +0200, Severin Gehwolf wrote:
> Hi,
> 
> Could somebody please review this build fix for libfontmanager.so. The
> issue for us is that with some LDFLAGS the build breaks as described in
> bug JDK-8196218. However, we cannot link to a providing library at
> build-time since we don't know which one it should be: libawt_headless
> or libawt_xawt. That has to happen at runtime. The proposed fix filters
> out relevant linker flags when libfontmanager is being built. More
> details are in the bug.
> 
> Bug: https://bugs.openjdk.java.net/browse/JDK-8196516

Latest webrev:
http://cr.openjdk.java.net/~sgehwolf/webrevs/JDK-8196516/webrev.02/

> Testing: I've run this through submit[1] and got the following results.
> SwingSet2 works fine for me on F27. I'm currently running some more
> tests on RHEL 7.

I've finished testing on RHEL 7 by manually verifying that not both
libawt_xawt and libawt_headless get loaded when running SwingSet.

Could somebody tell me what this failure below is about?

Thanks,
Severin

> ---------------------
> Mach5 mach5-one-sgehwolf-JDK-8196516-20180409-1036-17877: Builds PASSED. Testing FAILURE.
> 
> 0 Failed Tests
> 
> Mach5 Tasks Results Summary
> 
> NA: 0
> UNABLE_TO_RUN: 0
> EXECUTED_WITH_FAILURE: 0
> KILLED: 0
> PASSED: 82
> FAILED: 1
> Test
> 
> 1 Failed
> 
> tier1-debug-jdk_open_test_hotspot_jtreg_tier1_compiler_2-windows-x64-
> debug-31 SetupFailedException in setup...profile run-test-prebuilt' ,
> return value: 10
> --------------------
> 
> Not sure what this test failure means. Could somebody at Oracle shed
> some light on this?
> 
> Thanks,
> Severin


More information about the build-dev mailing list