strange configure error on Linux Mint 18.3

Thomas Stüfe thomas.stuefe at gmail.com
Tue Apr 24 13:25:24 UTC 2018


Hi Adrian,

On Tue, Apr 24, 2018 at 3:01 PM, John Paul Adrian Glaubitz
<glaubitz at physik.fu-berlin.de> wrote:
> Hi Thomas!
>
> On 04/24/2018 02:50 PM, Thomas Stüfe wrote:
>>
>> I got a configure error on a fresh, virgin Linux Mint 18.3 install. I
>> have not yet installed anything on that box (the only thing I
>> installed is autoconf).
>
>
> Have you tried "apt build-dep openjdk-9"? This should install all the
> necessary build dependencies.

This is cool! I did not know that.

Unfortunately it seems not to work on my box:

thomas at mint18 /shared/projects/openjdk/jdk-jdk/source $ sudo apt-get
build-dep openjdk-9
Reading package lists... Done
E: You must put some 'source' URIs in your sources.list

>
>> This fails at a point where normally I would get suggestions about
>> which tools to install with apt-get (which, btw, is really nice).
>> config.log contains this:
>> (...)
>> /usr/bin/ld: cannot find crt1.o: No such file or directory
>> /usr/bin/ld: cannot find crti.o: No such file or directory
>> /usr/bin/ld: cannot find -lc
>> /usr/bin/ld: cannot find crtn.o: No such file or directory
>
>
> You're missing the Debian package libc6-dev:
>
> root at z6:~> dpkg -L libc6-dev |grep crt
> /usr/lib/x86_64-linux-gnu/Mcrt1.o
> /usr/lib/x86_64-linux-gnu/Scrt1.o
> /usr/lib/x86_64-linux-gnu/crt1.o
> /usr/lib/x86_64-linux-gnu/crti.o
> /usr/lib/x86_64-linux-gnu/crtn.o
> /usr/lib/x86_64-linux-gnu/gcrt1.o
> /usr/lib/x86_64-linux-gnu/grcrt1.o
> /usr/lib/x86_64-linux-gnu/rcrt1.o
> root at z6:~>
>
>> Weirdly enough the compiler is ran once with -qversion, which is an
>> AIX-only option, and once with -V, which is not valid either.
>
>
> This is perfectly normal and the way autoconf works. It tries various
> compiler options and runs various tests, including test compiles,
> and checks the result. autoconf cannot know in advance what toolchain
> and which operating system you are using, so it has to perform these
> tests. The error messages are normally just redirected to /dev/null
> and only show in config.log.

Ah, thanks for the explanation!

>
>> Has anyone seen this already? (Note that I used Mint18.3 as
>> development machine before and it just worked).
>
>
> Yes, it's perfectly normal when you try to configure OpenJDK without
> any of its build dependencies installed :).
>

:) Sure. As I wrote, I think the bug would be that configure does not
display nice "you should run apt-get xxxxx" messages like it used to.

> PS: If you are using a real Debian instead of Linux Mint, you get a
>     free Multi-Arch environment for free and can easily cross-build
>     OpenJDK for all the architectures found in Debian. Let me know
>     if you want me to write up a small HowTo.
>

Such a braindump from you would be surely welcome.

..Thomas

> Adrian
>
> --
>  .''`.  John Paul Adrian Glaubitz
> : :' :  Debian Developer - glaubitz at debian.org
> `. `'   Freie Universitaet Berlin - glaubitz at physik.fu-berlin.de
>   `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913


More information about the build-dev mailing list