Choosing which Visual Studio installation to use

Thomas Stüfe thomas.stuefe at gmail.com
Thu Feb 15 17:38:17 UTC 2018


Hi Erik,

On Thu, Feb 15, 2018 at 4:22 PM, Erik Joelsson <erik.joelsson at oracle.com>
wrote:

> Hello Thomas,
>
> If you have multiple versions installed, configure will pick the one to
> use in order of most supported. To explicitly pick one, you can use
> --with-toolchain-version=2010 (or some other number) and configure will
> look for that specific version of Visual Studio. Just pointing to an
> install dir or bin dir does not work because configure needs to know which
> version it is dealing with and we haven't implemented smart enough
> discovery logic to automatically figure that out.
>
>
Great, exactly what I was looking for!


> Note that I recently added configure support for 2015 and 2017 in JDK 11.
> This does NOT mean the product actually builds with those and configure
> will print warnings accordingly. We are working on properly supporting
> 2017, but it's apparently non trivial.
>
>
Yes, I was playing around with getting VS2017 to build, and wanted to test
changes with various VS versions. I see that Lois Foltan is quite active,
maybe I just wait till he is done.

..Thomas


> /Erik
>
>
>
> On 2018-02-14 03:24, Thomas Stüfe wrote:
>
>> Hi all,
>>
>> On Windows, if one has multiple VS installations side by side, is it
>> possible to choose which Visual Studio installation to use?
>>
>> Note that I start the configure script from within the cygwin shell.
>>
>> Thanks, Thomas
>>
>
>


More information about the build-dev mailing list