[10] RFR(S): 8189761: COMPANY_NAME, IMPLEMENTOR, BUNDLE_VENDOR, VENDOR, but no configure flag

Erik Joelsson erik.joelsson at oracle.com
Wed Jan 17 19:16:28 UTC 2018


Looks good to me. I can sponsor it.

/Erik


On 2018-01-17 08:03, Volker Simonis wrote:
> Hi,
>
> can I please have a review and sponsor for this change which finally
> exposes the various "vendor*" properties:
>
> java.vendor
> java.vm.vendor
> java.vendor.url
> java.vendor.url.bug
>
> as configure arguments:
>
> http://cr.openjdk.java.net/~simonis/webrevs/2018/8189761
> https://bugs.openjdk.java.net/browse/JDK-8189761
>
> With this change, "java.vendor" and "java.vm.vendor" still default to
> "Oracle Corporation" which is defined in System.c (for "java.vendor")
> and in vm_version.cpp (for "java.vm.version") unless the new
> "--with-vendor-name" option introduced by JDK-8193764 will be used in
> the configure step.
>
> If the "--with-vendor-name" option will be used, its value will now,
> with this change, also be assigned to both, the "java.vendor" and
> "java.vm.vendor" properties. I don't think that we need a separate
> configure option for "java.vm.vendor" because if somebody is building
> the OpenJDK with a different VM, he will own the source code of that
> VM anyway and can easily set "java.vm.vendor" in his code.
>
> For "java.vendor.url" and "java.vendor.url.bug" I've introduced the
> two new configure options "--with-vendor-url" and
> "--with-vendor-bug-url" which should be self explanatory. If they are
> not set, the old default values will be used.
>
> In the case of a VM crash, the HotSpot displays a second, different
> bug URL which is currently only configured in the arguments.cpp file.
> I've exposed this URL as well to configure with the new
> "--with-vendor-vm-bug-url" configure option. Again, if this option
> will not use, the VM will fall back to the old default value.
>
> Notice that this patch also fixes a bug introduced by "8193764: Cannot
> set COMPANY_NAME when configuring a build" because of which the jtreg
> test "test/jdk/tools/jlink/ReleaseImplementorTest.java" fails if the
> testee was configured without "--with-vendor-name". The problem is
> that the code introduced by 8193764 unconditionally sets COMPANY_NAME
> to the empty string, if no "--with-vendor-name" option was given. This
> overrides the default setting of COMPANY_NAME=N/A from
> $AUTOCONF_DIR/version-numbers.
>
> I want to bring this into jdk10 if possible.
>
> I need a sponsor because this change requires the regeneration of
> "generated-configure.sh" (which I've included in the webrev for your
> convenience only) and because it touches a HotSpot file and external
> contributors still can't push such changes :(
>
> Thank you and best regards,
> Volker



More information about the build-dev mailing list