RFR: Bug Pending: Build fails to compile jchuff.c

Adam Farley8 adam.farley at uk.ibm.com
Tue Jan 23 14:13:31 UTC 2018


> On 01/23/2018 02:44 PM, Adam Farley8 wrote:
>> John: I read your email, and I understand your position. I disagree 
with it,
>> but I understand it. 4.8.5 is an old version of gcc, but right now it 
is the
>> listed gcc version for SUSE sles on intel, ppc, ppcle, and zLinux. Even 
if
>> this is not the case for JDK 10 or 11, we should ensure this fix is 
fully
>> propagated to ensure consistent behaviour.
>> 
>> That is my position.
> I happen to work at SUSE. And while you're right that SLE-12:GA is on 
gcc
> 4.8.x, SLE-12 doesn't have openjdk-9 or openjdk-10 or even -11 in its
> update repositories (looking at the internal SUSE build system at the 
moment).
>
> openjdk-9 is part of SLE-15:GA which itself ships gcc-7.
>
> So, what exactly is the usecase for OpenJDK-9, 10 and 11?
>
> Adrian

Hi Adrian,

The URL supplied by David (Holmes) lists 4.8.5 as the gcc version for
building JDK9 on SLES 11.3/12.1. Whether it's in a repository or not, 
I read that as "this is the gcc version you should be building JDK9 on".

https://wiki.openjdk.java.net/display/Build/Supported+Build+Platforms

I asked for this change to be put in 10 and 11 because I don't know the 
minimum/recommended gcc version for jdk10 and 11. I'm assuming it's 
the same as 9 until told otherwise.

Best Regards

Adam Farley

Unless stated otherwise above:
IBM United Kingdom Limited - Registered in England and Wales with number 
741598. 
Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU


More information about the build-dev mailing list