windows cygwin version test too strict

Thomas Stüfe thomas.stuefe at gmail.com
Fri Nov 9 15:09:01 UTC 2018


Hi all,

When running configure on Windows, I get now:

configure: Your cygwin is too old. You are running 2.11.2(0.329/5/3),
but at least cygwin 1.7 is required. Please upgrade.

When looking at basics_windows.m4:

    CYGWIN_VERSION_OK=`$ECHO $CYGWIN_VERSION | $GREP ^1.7.`
    if test "x$CYGWIN_VERSION_OK" = x; then
      AC_MSG_NOTICE([Your cygwin is too old. You are running
$CYGWIN_VERSION, but at least cygwin 1.7 is required. Please
upgrade.])
      AC_MSG_ERROR([Cannot continue])
    fi

So, we explicitly need version 1.7? Higher won't do?

Thanks, Thomas


More information about the build-dev mailing list