windows cygwin version test too strict

Thomas Stüfe thomas.stuefe at gmail.com
Fri Nov 9 15:28:44 UTC 2018


Please ignore all my mails. My repository was just off. I did a fresh
re-clone, now all is fine.

Thanks, Thomas
On Fri, Nov 9, 2018 at 4:13 PM Thomas Stüfe <thomas.stuefe at gmail.com> wrote:
>
> ..bypassing this version check yields a similar error later on, where
> a more modern GNUmake is not accepted:
>
> configure: Found GNU make at /usr/bin/make, however this is not
> version 3.81 or later. (it is: GNU Make 4.2.1). Ignoring.
> configure: error: Cannot find GNU make 3.81 or newer! Please put it in
> the path, or add e.g. MAKE=/opt/gmake3.81/make as argument to
> configure.
>
> ..Thomas
> On Fri, Nov 9, 2018 at 4:09 PM Thomas Stüfe <thomas.stuefe at gmail.com> wrote:
> >
> > Hi all,
> >
> > When running configure on Windows, I get now:
> >
> > configure: Your cygwin is too old. You are running 2.11.2(0.329/5/3),
> > but at least cygwin 1.7 is required. Please upgrade.
> >
> > When looking at basics_windows.m4:
> >
> >     CYGWIN_VERSION_OK=`$ECHO $CYGWIN_VERSION | $GREP ^1.7.`
> >     if test "x$CYGWIN_VERSION_OK" = x; then
> >       AC_MSG_NOTICE([Your cygwin is too old. You are running
> > $CYGWIN_VERSION, but at least cygwin 1.7 is required. Please
> > upgrade.])
> >       AC_MSG_ERROR([Cannot continue])
> >     fi
> >
> > So, we explicitly need version 1.7? Higher won't do?
> >
> > Thanks, Thomas


More information about the build-dev mailing list