<AWT Dev> [12] Gcc 8.1 HarfBuzz library compilation issues

Simon Tooke stooke at redhat.com
Tue Nov 20 18:35:30 UTC 2018


On 2018-11-20 10:04 a.m., Philip Race wrote:
> I have removed awt-dev and replaced it with the CORRECT 2d-dev list.
> Please reply to this one .. to get awt-dev out of the loop.
> I already have an open bug to upgrade harfbuzz I will be handling soon.
> If the necessary changes are there we are all good.
> We do not much like at all locally modifying sources we get from
> upstream.
> It is a maintenance nightmare.

I appreciate that, and am happy to wait for the harfbuzz version upgrade.
I didn't see it before, but now I see it's implied by 82121157.

Thanks,
-Simon


>
> -phil
>
> On 11/20/18, 6:48 AM, Simon Tooke wrote:
>> On 2018-11-20 5:31 a.m., Magnus Ihse Bursie wrote:
>>> On 2018-11-19 22:22, Simon Tooke wrote:
>>>
>>>> Hello,
>>>>
>>>> I've been looking at compiling the JDK with GCC 8.1, and trying to fix
>>>> issues upstream as I find them.
>>> Nice! If you find issues in the JDK source code per se, please let us
>>> know. :) Sooner or later, we'll have to support gcc 8 properly anyway,
>>> might just as well try to clear the path already.
>> I noticed yesterday that
>> https://bugs.openjdk.java.net/browse/JDK-8213153 from Dmitry Chuyko is
>> also working on GCC 8.  I am not sure how far down the rabbit hole he
>> is, but I (with the kind assistance of Severin Gehwolf since I'm not a
>> committer) am submitting a series of patches to move towards that. I
>> have a JDK tree compiling with 8.1, but it still has to disable warnings
>> in more places than I feel comfortable with.
>>
>>> /Magnus
>>>> For example the version of HarfBuzz shipped in the JDK has some issues
>>>> with template specialization and with clearing a struct via memset()
>>>> (thus bypassing C++ member access restrictions).
>>>>
>>>> I've had changes to address these issues accepted upstream [1], and I
>>>> was wondering if it is appropriate for me to file an issue to backport
>>>> those fixes (I have a patch ready) or do you prefer to wait until
>>>> HarfBuzz is upgraded to the latest version during the natural
>>>> course of
>>>> JDK development.
>>>>
>>>> (Be aware that the JDK is on a 1.7 version, while these fixes are in a
>>>> 2.X version).
>>>>
>>>> Thanks,
>>>> -Simon
>>>>
>>>> [1] https://github.com/harfbuzz/harfbuzz/pull/1334
>>>>



More information about the build-dev mailing list