RFR: 8219920: dependency help output in configure-step : support zypper tool

Baesken, Matthias matthias.baesken at sap.com
Fri Mar 1 08:48:06 UTC 2019


Btw.  Speaking about  help.m4 help output ,   the mentioning of openjdk-8-jdk  in the various package-installer help outputs  seems to be outdated and  misleading to me :

  88 apt_help() {
  89   case $1 in

   . . .
  94     openjdk)
  95       PKGHANDLER_COMMAND="sudo apt-get install openjdk-8-jdk" ;;
  96     alsa)
  97       PKGHANDLER_COMMAND="sudo apt-get install libasound2-dev" ;;

I  think  we would need   jdk11 by  now (or soon jdk12, but  I am not sure about package  availability at the various distros for  12).

Best regards, Matthias



From: Baesken, Matthias
Sent: Donnerstag, 28. Februar 2019 13:53
To: 'build-dev at openjdk.java.net' <build-dev at openjdk.java.net>
Cc: Zeller, Arno <arno.zeller at sap.com>; Simonis, Volker <volker.simonis at sap.com>
Subject: RFR: 8219920: dependency help output in configure-step : support zypper tool

Hello, please review the following  change .

Currently  the  configure-step  outputs  help  for  a number of  packages + related installation calls  in case of missing dependencies  (like cups / alsa etc.) .
This help output step   covers a few  tools (like apt-get).


However the OpenSUSE / SLES tool zypper  is not supported .
This  change adds  output for  zypper .

Bug/webrev:

https://bugs.openjdk.java.net/browse/JDK-8219920

http://cr.openjdk.java.net/~mbaesken/webrevs/8219920.0/


Thanks, Matthias


More information about the build-dev mailing list