RFR: [8u] Build failed on Ubuntu 18.04 due to deprecated-declarations warnings

Andrew Haley aph at redhat.com
Tue Mar 19 14:45:48 UTC 2019


On 3/19/19 12:25 PM, Jie Fu wrote:
> To fix build failures caused by deprecated-declarations warnings, can we 
> make this change to jdk8u?

This is very GCC-version dependent. We really should probe at configure time for
these options.

-- 
Andrew Haley
Java Platform Lead Engineer
Red Hat UK Ltd. <https://www.redhat.com>
EAC8 43EB D3EF DB98 CC77 2FAD A5CD 6035 332F A671


More information about the build-dev mailing list