RFR: [8u] Build failed on Ubuntu 18.04 due to deprecated-declarations warnings

Brian Burkhalter brian.burkhalter at oracle.com
Tue Mar 19 15:15:12 UTC 2019


jdk8u-dev will build with this conf

bash configure --with-extra-cflags=-Wno-error

at least on Ubuntu 18.04.

> On Mar 19, 2019, at 8:09 AM, Martin Buchholz <martinrb at google.com> wrote:
> 
> Probably it's because glibc deprecated readdir, and we don't have
> --disable-warnings-as-errors by default?
> 
> (I think warnings should not be errors except as opt-in by openjdk
> developers/maintainers)
> 
> On Tue, Mar 19, 2019 at 7:47 AM Andrew Haley <aph at redhat.com> wrote:
> 
>> On 3/19/19 12:25 PM, Jie Fu wrote:
>>> To fix build failures caused by deprecated-declarations warnings, can we
>>> make this change to jdk8u?
>> 
>> This is very GCC-version dependent. We really should probe at configure
>> time for
>> these options.
>> 
>> --
>> Andrew Haley
>> Java Platform Lead Engineer
>> Red Hat UK Ltd. <https://www.redhat.com>
>> EAC8 43EB D3EF DB98 CC77 2FAD A5CD 6035 332F A671
>> 



More information about the build-dev mailing list