PROPOSAL: Named method parameters

rssh at rssh at
Sun Mar 22 09:14:15 PDT 2009

>void method(int a, String b) and void method(String b, int a)
> Currently these are treated as separate methods and can be resolved
> correctly, but if named parameters allowed you to reorder them, then it
> might be more difficult to choose the correct implementation (particularly
> if there are other parameters that are not reordered, and/or you have a
> hierarchy of overridden and overloaded classes).  This would also require

(In java we already have such situation with varargs and autoboxing - JSL
specify choose method with minimum number of transformations between
argument list and set of method parameters)  Also I belive, that just
raise compiler error when changes only permutations are acceptable.

More information about the coin-dev mailing list