RFR: JDK-8250768: javac should be adapted to changes in JEP 12 [v4]

Jonathan Gibbons jjg at openjdk.java.net
Mon Nov 2 20:25:12 UTC 2020

On Tue, 27 Oct 2020 16:09:45 GMT, Jan Lahoda <jlahoda at openjdk.org> wrote:

>> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclets/formats/html/AbstractExecutableMemberWriter.java line 88:
>>> 86: 
>>> 87:     @Override
>>> 88:     protected Content getDeprecatedOrPreviewLink(Element member) {
>> This name is a side-effect of the `ElementFlag` question.  We should either use explicit field and method names, or we should use `ElementFlag` more consistently.   This method name works OK for now, but if if ever gets to have another `orFoo` component in the name, the signature should be parameterized with something like `ElementFlag` or its equivalent.
> Note this method returns the same link for deprecate or preview - it just was named "getDeprecatedLink", and when using it work preview, I renamed it "getDeprecatedOrPreviewLink". We may need to think of a better name.

This name is OK for now. Maybe we'll have m ore insight into a better name if/when we add a third variant ;-)


PR: https://git.openjdk.java.net/jdk/pull/703

More information about the compiler-dev mailing list