hg: jdk7/tl/jdk: 6701459: Synchronization bug pattern found in javax.management.relation.RelationService

Rob Leland java.net at freetocreate.org
Wed May 14 18:34:15 UTC 2008

Hi Eamonn,

In the change sets some variable postfixes were renamed
Nbr  -> No

Long seqNbr = getNotificationSequenceNumber();
+ Long seqNo = atomicSeqNo.incrementAndGet();

The abbreviation No could also could mean:
 No as in 'Yes'/'No' ,
 No as in 'Notation',
 besides 'Number'.
Generally avoiding unclear naming seems desirable.
Comments ?

-Rob Leland

More information about the core-libs-dev mailing list