Code review request for 6998871 "Support making the Throwable.stackTrace field immutable"
David.Holmes at oracle.com
Thu Apr 7 08:03:42 UTC 2011
Dmytro Sheyko said the following on 04/07/11 17:50:
> Just wonder what is the purpose of dummy parameter in native fillInStackTrace method. Couldn't we simply rename it (e.g. to fillInStackTrace0)
Using an overload instead of renaming the native method was initially
done to avoid having to make changes to the stacktrace filtering code in
the VM. It turns out that we need to make a change anyway, but it is
easier if we stick with the one name for the method to be filtered out.
This isn't set in concrete though.
>> Date: Wed, 6 Apr 2011 23:29:02 -0700
>> From: joe.darcy at oracle.com
>> To: core-libs-dev at openjdk.java.net
>> Subject: Code review request for 6998871 "Support making the Throwable.stackTrace field immutable"
>> Returning to some earlier work, I've developed a proposed fix for
>> 6998871 "Support making the Throwable.stackTrace field immutable"
>> One constructor of Throwable now takes an additional boolean argument to
>> make the stack trace information immutable. Analogous constructors are
>> added to Exception, RuntimeException, and Error.
>> Mandy and David have already reviewed the change; I'm interested in
>> getting additional feedback on the design of the API.
More information about the core-libs-dev