<i18n dev> Fwd: Re: Codereview Request: 7039066 j.u.rgex does not match TR#18 RL1.4 Simple Word Boundaries and RL1.2 Properties

Alan Bateman Alan.Bateman at oracle.com
Tue Apr 26 09:20:39 UTC 2011

Xueming Shen wrote:
>  Thanks Mark!
> Let's go with UNICODE_PROPERTY, if there is no objection.
I went through the updates to the javadoc and the approach looks good 
and nicely done. A minor comment is that the compile(String,int) method 
repeats the list of flags that are allowed so that should be updated to 
list the new flag. I don't know if you have a reviewer for the 
implementation changes yet; if not then I'll try to go through them 
later in the week.

It looks like the outstanding question is the name of the flag. As it 
enables the predefined and POSIX character classes to be the Unicode 
versions then I think UNICODE_CHARACTER_CLASS (or _CLASSES) would be 
clearer to the reader. UNICODE_CLASSES is shorter but might cause 
someone to think java.lang.Class rather than character classes. I'm not 
sure whether the singular or plural name is better but the existing 
flags are a mix of singular and plural.

More information about the core-libs-dev mailing list