Code review: 7012540 (java.util.Objects.nonNull() incorrectly named)

Brian Goetz brian.goetz at
Thu Jan 27 14:31:27 UTC 2011

> About the name, I propose:
> iUsedToUseGetClassHereButNodobyWasAbleToUnderstand()

But there are two methods we want to rename this to, and we can't use 
this name twice.  I propose we generate random method names instead.

More information about the core-libs-dev mailing list