Code review: 7012540 (java.util.Objects.nonNull() incorrectly named)
jason_mehrens at hotmail.com
Thu Jan 27 16:04:11 UTC 2011
> > About the name, I propose:
> > iUsedToUseGetClassHereButNodobyWasAbleToUnderstand()
> But there are two methods we want to rename this to, and we can't use
> this name twice. I propose we generate random method names instead.
You don't want to violate trademarks either.
How about 'vetoNull' derived from the java.beans API. Not that it is a great name but, it is short, the meaning of veto in that context is used to deal with unacceptable values by throwing, and the beans API is already well established.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the core-libs-dev