Code review: 7012540 (java.util.Objects.nonNull() incorrectly named)
David M. Lloyd
david.lloyd at redhat.com
Fri Jan 28 14:47:34 UTC 2011
On 01/27/2011 10:58 PM, David Holmes wrote:
> Rémi Forax said the following on 01/27/11 18:43:
>> On 01/27/2011 09:38 AM, Stephen Colebourne wrote:
>>> As I said before, removing this method is the best option now. Get it
>>> right in v8.
>> I think we can't.
>> This method is already used at many place in the JDK.
> I think we can. Those usages will have to be modified anyway. If it is
> really the wrong decision to add this now, and if we really can't get
> some consensus on the best name for the exception throwing method, then
> we should remove it.
> I'm not saying we're in that position, just that if we were there's no
> reason we could not undo this.
> I think the utility and significance of this method is vastly
> over-estimated, and certainly not worth the level of activity it has
Everyone likes a good bike-shed-painting session.
More information about the core-libs-dev