Request for review: 6312706: Map entrySet iterators should return different entries on each call to next()

Mike Duigou mike.duigou at
Thu Mar 31 19:59:55 UTC 2011

On Mar 30 2011, at 09:07 , Neil Richards wrote:

> On Tue, 2011-03-29 at 15:09 -0700, Mike Duigou wrote:
>> Neil, do you have a strong reason or preference for using an anonymous inner Object [for NULL]?
> Hi Jason, thanks for your review and suggestion.
> In summary, as using 'new Integer(0)' for NULL would save on having an
> extra Class definition, I'm all in favour of adopting your amendment -
> thanks once again.
> Mike, are you happy to make this simple modification to the changeset,
> or shall I send you an updated version ?

I will make the modification as Jason suggested and commit this issue today.


More information about the core-libs-dev mailing list