field "path" is not declared final

Rémi Forax forax at
Fri Feb 17 12:54:15 UTC 2012

On 02/17/2012 01:41 PM, Alan Bateman wrote:
> On 17/02/2012 12:37, David Holmes wrote:
>> On 17/02/2012 10:11 PM, Alan Bateman wrote:
>>> On 17/02/2012 12:00, Rémi Forax wrote:
>>>> :
>>>> Better with the attachment inlined :)
>>> Thanks Rémi, this looks okay to me although I probably would have used
>>> putObjectVolatile for the path field.
>> You only need one "volatile" store and it should be the last one. The 
>> approximate affect is:
>> path = ...
>> membar: LoadStore | StoreStore
>> prefixlength = ...
>> membar: StoreLoad
> I understand, I just remarking that I probably would have used a 
> volatile store for both to make it clearer but that would be less 
> efficient.

Knowing that some codes already serialize File instances, I wanted
to minimize the perf impact of this change.
That's why I've put only one volatile store even if I agree with Alan that
it's better to use two putObjectVolatile for the readability.

> -Alan


More information about the core-libs-dev mailing list