field "path" is not declared final

Ulf Zibis Ulf.Zibis at
Sun Feb 19 17:30:03 UTC 2012

Am 17.02.2012 13:54, schrieb Rémi Forax:
> On 02/17/2012 01:41 PM, Alan Bateman wrote:
>> I understand, I just remarking that I probably would have used a volatile store for both to make 
>> it clearer but that would be less efficient.
> Knowing that some codes already serialize File instances, I wanted
> to minimize the perf impact of this change.
> That's why I've put only one volatile store even if I agree with Alan that
> it's better to use two putObjectVolatile for the readability.

Maybe too late, but what about adding a comment on that to the source code.


More information about the core-libs-dev mailing list