Review Request CR#7118743 : Alternative Hashing for String with Hash-based Maps

Mike Duigou mike.duigou at
Sat May 26 18:15:25 UTC 2012

On May 26 2012, at 08:43 , Ulf Zibis wrote:

> Am 24.05.2012 21:34, schrieb Mike Duigou:
>> Hello All;
>> I have updated the webrevs for alternative hashing for String with feedback from Remi, Doug, Ulf and internal reviewers.
>> Additional feedback is welcome.
> Javadoc of String.hash32():

> To where refers {@inheritDoc} ?

To the new interface java.lang.Hashable32.hash32()

> I think, the javadoc should mention the term 'Murmur hash' and include a web link to the original author.

Explicitly NO. This new hashing interface will not document it's algorithm so that unlike String.hashCode() we can change it in the future if we need to.

> And additionally IMO we should rename hash32() to something like murmurHash32().

No, for the previous reason.

> But I still think, we should implement a more general approach according my last post.

It seems to be overkill to me and of very limited value. New Map implementations could be created by third parties if this is useful to some users.


More information about the core-libs-dev mailing list