8010309 : PlatformLogger: isLoggable performance / waste due to HashMap<Integer, Level> leads to Integer allocations (boxing)
bourges.laurent at gmail.com
Fri Mar 22 13:41:34 UTC 2013
that's OK for me and the code is clearer.
> What remains is a possible rename from: javaLogger, javaLevel,
> JavaLoggerProxy -> julLogger, julLevel, JulLoggerProxy if that's the final
I vote for jul prefix that is more explicit; as I said, java means anything
but not specifically java.util.logging.
More information about the core-libs-dev