RFR: Optimize StringBuilder.append(null)

Martin Buchholz martinrb at google.com
Thu Mar 28 16:05:52 UTC 2013

I took Laurent's suggestion of renaming count to c, even though the result
looks like a value judgement on a competing programming environment:

        value[c++] = 'n';
        value[c++] = 'u';
        value[c++] = 'l';
        value[c++] = 'l';

On Wed, Mar 27, 2013 at 11:42 PM, Laurent Bourgès <bourges.laurent at gmail.com
> wrote:

> Maybe the local var count could be renamed _count or c to avoid name
> conflict with the member count and make the code more readable / obvious.

More information about the core-libs-dev mailing list