RFR 8065998: Avoid use of _ as a one-character identifier

Andreas Lundblad andreas.lundblad at oracle.com
Mon Dec 1 13:01:03 UTC 2014

On Mon, Dec 01, 2014 at 01:10:29PM +0100, Jan Lahoda wrote:
> Hi,
> In a preparation for JDK-8061549, I'd like to rename all uses of '_'
> as a one-character identifier in the jaxp and jdk repositories. All
> the uses I was able to find are in tests, and the identifier is used
> as a name of a catch parameter. The proposed new name is "ignore",
> but if a different name would be more appropriate, I'll be happy to
> use it.

To me "ignore" signals "I don't care if this exception occurred." In tests, when an exception *should* occurr, I usually name the variable "expected". Ignore is a bit shorter though, so in the end it's a matter of taste I guess.

-- Andreas

More information about the core-libs-dev mailing list