RFR 8065998: Avoid use of _ as a one-character identifier

Martijn Verburg martijnverburg at gmail.com
Mon Dec 1 13:00:47 UTC 2014

I know this is descending into bike shedding - but I like that split of
definition, shamelessly stealing for my future projects, thanks!


On 1 December 2014 at 13:01, Andreas Lundblad <andreas.lundblad at oracle.com>

> On Mon, Dec 01, 2014 at 01:10:29PM +0100, Jan Lahoda wrote:
> > Hi,
> >
> > In a preparation for JDK-8061549, I'd like to rename all uses of '_'
> > as a one-character identifier in the jaxp and jdk repositories. All
> > the uses I was able to find are in tests, and the identifier is used
> > as a name of a catch parameter. The proposed new name is "ignore",
> > but if a different name would be more appropriate, I'll be happy to
> > use it.
> To me "ignore" signals "I don't care if this exception occurred." In
> tests, when an exception *should* occurr, I usually name the variable
> "expected". Ignore is a bit shorter though, so in the end it's a matter of
> taste I guess.
> -- Andreas

More information about the core-libs-dev mailing list