RFR 8065998: Avoid use of _ as a one-character identifier

Jan Lahoda jan.lahoda at oracle.com
Mon Dec 1 13:25:45 UTC 2014

Thanks, makes sense. I've updated the patches so that in cases where (I 
think) the exception is expected, the name is "expected". I used 
"unused" in other cases where the fact that an exception was thrown is 
not ignored, but where the value of the exception parameter is not used.

I've forgot (sorry for that) that in jaxp tests, there are two unused 
method parameters named _ - I've named them "unused" as well.

Updated patches:

Does this make sense?



On 1.12.2014 14:01, Andreas Lundblad wrote:
> On Mon, Dec 01, 2014 at 01:10:29PM +0100, Jan Lahoda wrote:
>> Hi,
>> In a preparation for JDK-8061549, I'd like to rename all uses of '_'
>> as a one-character identifier in the jaxp and jdk repositories. All
>> the uses I was able to find are in tests, and the identifier is used
>> as a name of a catch parameter. The proposed new name is "ignore",
>> but if a different name would be more appropriate, I'll be happy to
>> use it.
> To me "ignore" signals "I don't care if this exception occurred." In tests, when an exception *should* occurr, I usually name the variable "expected". Ignore is a bit shorter though, so in the end it's a matter of taste I guess.
> -- Andreas

More information about the core-libs-dev mailing list