RFR 8065998: Avoid use of _ as a one-character identifier
joe.darcy at oracle.com
Mon Dec 1 17:54:34 UTC 2014
The changes look good to me; thanks,
On 12/1/2014 5:37 AM, Jan Lahoda wrote:
> On 1.12.2014 14:20, Alan Bateman wrote:
>> On 01/12/2014 12:10, Jan Lahoda wrote:
>>> In a preparation for JDK-8061549, I'd like to rename all uses of '_'
>>> as a one-character identifier in the jaxp and jdk repositories. All
>>> the uses I was able to find are in tests, and the identifier is used
>>> as a name of a catch parameter. The proposed new name is "ignore", but
>>> if a different name would be more appropriate, I'll be happy to use it.
>>> Webrev for the jaxp repository:
>>> Webrev for the jdk repository:
>> In JAXP test Bug4969089 then "ignore" looks a bit odd given that it's in
>> a method declaration.
> Sorry for that - I've forgot about these uses in method declarations.
> I've updated the patch to use "unused" for them.
>> In TypeCheckMicroBenchmark then "ignore" is might be a misleading too
>> given that the ArrayStoreException causes a CCE to be thrown.
> I've updated the patch to use "expected" where the exception appears
> to be expected and "unused" where exception appears to be unexpected,
> but the variable is not used.
> Updated patches:
More information about the core-libs-dev